Jeśli chcecie mnie wesprzeć to zapraszam do kupna mojego poradnika "Jakim jesteś Makiem?".

Snow Leopard – problemy

· Wojtek Pietrusiewicz · 15 komentarzy

Pomimo, że Apple kontroluje platformę sprzętową na jakiej instalowane są jego systemy operacyjne to już kolejny raz niektórzy użytkownicy mają problemy z tym procesem. Osobiście mnie to nie dziwi – programiści musieli być psychopatami aby pisać takie ilości linijek kodu bez jakichkolwiek błędów. Z drugiej strony, z tego co zaobserwowałem, sam proces instalacji u większości przebiega poprawnie co sugeruje, że nietypowe hacki/mody/programy są istotą błędów w upgrade do Snow Leopard.

Jeśli przed uaktualnieniem chcecie sprawdzić czy wszystkie Wasze aplikacje będą prawidłowo działały to zapraszam tutaj: SnowLeopard.wikidot.com – znajdziecie tam listę najpopularniejszych programów i dodatków do OS X oraz notkę obok z informacją dotyczącą kompatybilności ze Snow Leopard.

Dodatkowo zalecam zrobienie jednej rzeczy przed wykonaniem uaktualnienia – naprawienie uprawnień na dysku! Aby to zrobić należy uruchomić Disk Utility / Narzędzie Dyskowe i zrobić co następuje:

  • z lewej strony wybrać nasz dysk, zazwyczaj Macintosh HD
  • na dole wcisnąć przycisk Repair Disk Permissions / Napraw uprawnienia na dysku
  • po paru minutach uprawnienia zostaną naprawione i dopiero teraz przystąpić do upgrade’u

Problemy z programami

aBlip:

  • program dalej lubi się przywiesić i nie odświeżać nowych blipnięć – tak jak na 10.5.x
  • nie działa podgląd załączonych zdjęć do wiadomości
  • nie działają linki wklejony w blipnięciach – są widoczne, ale po kliknięciu jesteśmy przekierowywani na dziwne i zdecydowanie błędne adresy

Growl:

  • należy wejść do ustawień Growl w Preferencjach Systemowych i go wyłączyć – pozostaje nam czekać na update gdyż powoduje problemy w tle i duże memory leaks

Wacom Intuos4 – driver:

  • niby wszystko działa, ale jeden z instalowanych kextów nie funkcjonuje – nie zauważyłem żadnych konsekwencji tego problem
  • zgłosiłem fakt do Wacoma
  • trochę wtopa, ale działa wszystko dlatego, że ten kext z jakiegoś powodu wyrzuca error przy instalacji drivera Wacoma, ale nie ma nic z nim wspólnego :)

Cisco VPN Client:

Od ^Sergiopl na Blipie dowiedziałem się że miał problemy z VPNem już za czasów upgrade’u do Leopard z Tigera. Tym razem postanowił zrobić czystą instalację. Oto jego słowa:

Więc od początku. Maszyna macbook pro 15.4″ alu 2.4 GHz, santa rosa 2007. Kupiony z Tigerem, niestety dwa tygodnie za wcześnie (przed okresem ochronnym darmowego Leoparda). W dniu premiery Leo kupiłem wersję retail w iSpocie i zrobiłem „nakładkę” na system. (Wcześniej robiąc sobie image dysku na innym komputerze) Aktualizacja poszła, jednak system się wysypywał przy uruchamianiu vpn clienta (kernel panic). Druga próba bez klienta poszła w miarę gładko… do czasu instalacji aktualizacji 10.5.1. Wtedy system zapętlił się i wrzucał mnie do first run. Nie pamiętam co mu wtedy zrobiłem, ale podjąłem decyzję o puszczeniu clean install z zarchiwizowaniem obecnego systemu w podkatalogu. System się zainstalował, zaktualizował i pracował bardzo stabilnie. Dokumenty powyciągałem z zarchiwizowanego katalogu i byłem szczęśliwy. Nawet VPN Client dał się zainstalować, od czasu do czasu wyświetlając tylko błąd o braku dostępności interfejsów IP. Wtedy pomagał restart rozszerzenia (tak jak w tej instrukcji) Niedawno (jeszcze na 10.5) zainstalowałem nowszego klienta 4.9.01.180-universal i w zasadzie problem znikł.

Nauczony tymi doświadczeniami (i trochę doświadczeniem z Windows) Snow Leoparda od razu zainstalowałem na czysty dysk (wymieniłem 160 GB -> 320 GB przy okazji). VPN clienta jeszcze nie zainstalowałem. Póki co próbuję dać szansę klientowi VPN Apple i byłoby wszystko ok, gdyby korzystał z DNSu mojej sieci wewnętrznej (dostaje go przez DHCP ale ignoruje). Tymczasowe rozwiązanie, które stosuję to dwie lokalizacje (automatyczna i dom-vpn). W tej drugiej utworzyłem interfejs VPN, a w interfejsie Airport wpisałem na sztywno jako jedyny DNS firmowy. Wtedy, jak nawiążę połączenie VPN mogę korzystać bez przeszkód z firmowych zasobów z użyciem DNS.

Logitech Control Centre i myszka tej firmy:

Z kolei ^vinci na Blipie raportuje problemy z myszką Logitecha – mianowicie nie działa Expose z nią.

Małe problemy na staryszych Makach u Engadget:

Serwis Engadget.com raportuje, że na ogól nie mieli problemów ze Snow Leopard poza starszym dwuletnim iMakiem, który od nowości nie był przeinstalowywany nowym systemem – problemy rozwiązali w kilka minut, ale radzą użytkownikom którzy już teraz spotykają dziwne zachowania na Leopard do wykonania czystej instalacji.

Installation itself took about 45 minutes on most of the machines we tried, although we did run into some snags once things were complete. We didn’t have any problems with the more pristine MacBook Pros in our fleet, but one of our production machines is a cranky older iMac that’s been in constant use for over two years without a system rebuild, and when it restarted the desktop pictures were all set to the defaults, the System Preferences app wouldn’t launch from the Apple Menu, our MobileMe sync states were a little confused and Spotlight began reindexing all the external drives. Fixing these problems didn’t take much, but if your machine is already acting up don’t expect everything to go perfectly.

Link do artykułu: Engadget Snow Leopard Review

Tematy na forach Apple:

Niejaki Wayne Christian1 ma problemy z zamontowaniem zewnętrzynych dysków USB, które mu prawidłowo funkcjonowały do momentu upgrade’u. Do jego prośby pomocy dołączyło dwóch kolejnych poszkodowanych.

Matsuda86 natomiast narzeka na powolne działanie Expose – podobnie jak ja w poprzednich wpisach. Z odpowiedzi wynika, że nie wszyscy są skazani na ten problem i jedna osoba nawet zaproponowała rozwiązanie, ale nie wiedząc co to jest ani co dokładnie robi nie odważę się tego wypróbować.

jbracoo jest jednym z mniej szczęśliwych użytkowników Snow Leopard gdyż w ogóle nie może się zalogować do własnego komputera poza trybem Safe. O takich przypadach też czytałem w komentarzach pod artykułami na innych stronach, więc też nie wygląda to na odosobniony przypadek, ale też nie dotyczy wielu osób.

Zmiana funkcjonalności w Snow Leopard:

Jedna funkcja, które zmieniła swoje działanie i niezwykle zirytowała Larry McJunkina jest okienko proszące o hasło po wyjściu komputera z uśpienia/uśpienia ekrany/screensavera – teraz wystarczy np. niechcący przesunąć myszką w gorący róg ekranu (funkcja Expose) i nawet to zaledwie ułamku sekundy komputer prosi o podanie hasła. Zapewne ma to związek ze zwiększeniem bezpieczeństwa i sam osobiście na to nie będę narzekał.

Tymczasem odpowiadając na niektóre blipnięcia – jestem bardzo zadowolony z uaktualnienia do Snow Leopard – gdyby jeszcze Expose/Spaces działał płynnie to nie miałbym żadnych zastrzeżeń. Może jak w końcu zdecyduję się na wymianę i montaż większego dysku w moim MBP to to się zmieni … a tymczasem czekam na inne rozwiązania.

PS. Właśnie zauważyłem na Blipie, że ^wieslaw raportuje problemy z drukarką – nie sprecyzował jaką – która mu przestała działać po upgrade.

Chcesz zwrócić mi na coś uwagę lub skomentować? Zapraszam na @morid1n lub na forum.

  • Największym problemem Snow Leoparda jest chyba jego dostępność, a raczej jej brak ;] Trochę to śmieszne, żeby w całej Warszawie praktycznie nie można było już w piątek po 18 dostać systemu ;)

  • Przepraszam z całego serca że na miejscu wykupiłem 3 sztuki. :) Wiele osób zaopatrywało się w więcej niż jedną kopię z tego co widziałem – to było o godz. 13:30-14:00 w iSpot Galeria Mokotów. Powiem tak – jestem i tak pod wrażeniem że kraj 3. świata jakim jest Polska dla Apple dostał jakiekolwiek Snow Leopard w dniu premiery … Wiele osób dzwoniło i prosiło o odłożenie pod ladę – tak zrobił kolega i zakupił dopiero w sobotę w Arkadii. Zgadzam się jednak z tym, że powinno być ich więcej. Może po prostu iSource nie spodziewał się takiej sprzedaży?

  • Jony

    W Gdańsku to samo. W sklepie było (chyba) tylko tyle kopii, ile ludzie zamówili przez internet, także 30min po wejściu do sprzedaży towar był niedostępny. Trochę to mało profesjonalne. Z tegoż powodu upgrade i testowanie nowego systemu muszę przełożyć o kilka dni.

  • Ale ja nie mam o to do Ciebie pretensji ;] Po prostu jest to dziwne, że po wyjściu z pracy nie mogłem już nigdzie w rozsądnej odległości od biura i domu dostać SL. W sumie miałem wyjść w ciągu dnia specjalnie, żeby kupić, no ale nie udało mi się wyrwać i muszę obejść się na razie smakiem.
    W sumie też troszkę dziwi mnie Twoja postawa – cieszmy się, że w ogóle był – wg mnie taka sytuacja nie powinna mieć miejsca i spokojnie można było tę premierę o tydzień przełożyć, żeby spokojnie i wszędzie odpowiednia ilość płytek z nowym systemem trafiła. No ale skoro Apple chciało tak bardzo wyprzedzić ogłoszony przez siebie termin, to mamy za swoje :)

  • Po prostu przyzwyczailem się do faktu ze jesteśmy traktowani gorzej niż inni.

    via iPhone

  • Rafal

    drukarka ricoh sp c220n nie bangla.

  • Sergio

    Witaj.
    Dzięki za cytat. Jak obiecałem tak zrobiłem i zainstalowałem Cisco VPN Client 4.9.01 (100) na Snow Leopardzie. Łączy się poprawnie. Zrobiłem kilka restartów maszyny, za każdym razem wstawała i łączyła się prawidłowo. DNSy z sieci VPN również działają z automatu. Wygląda na to, że Apple musi lepiej dopracować klienta VPN (ma te same kłopoty co ten z iPhone – nie korzysta z DNSu podawanego przez sieć VPN).

    Karol, Jony – przejeżdżałem dziś obok warszawskiego MediaMarktu w Al. Krakowskiej, więc zajrzałem. Leżało do wzięcia kilka kopii systemu po 129zł.

  • Chino

    Witaj,
    opisując problem z tabletem Wacom, pojawił się on po instalacji nowych driverów beta do 10.6, czy ten problem pojawił się na starych driverach do 10.5?

  • Upgrade zrobiłem na driverze z 10.5. Po upgradzie do bety (nie widziałem info ze to jest do 10.6) pojawił się error.

    Pózniej spróbuje całkiem wyrzucić tablet i od nowa dodać. Dam znać.

  • ebeneben

    Apropo rwania expose pomyślałem, że to Cię zainteresuje Moridinie.
    Na forum myapple pan „narkoman.” najpierw cytuje a potem pisze:
    ______________________________________________________________
    „Cytat:
    Autorem cytatu jest Opoya Zobacz post
    Instalowałam przez aktualizację – wszystko OK.
    Trzeba tylko pamiętać, by usunąc z System Preferences/Others niepotrzebne programiki (np. te, które nie działają z SL) oraz usunąć niepotrzebne „itemy” włączające się przy starcie systemu z SP/Accounts/Login Item”

    Powyczyszczałem to trochę tak jak napisałeś ze śmieci i póki co skończyły się problemy z szarpaniem puplitami/exposee, nie wiem czy to to pomogło czy kilka restartów ale jest okej już!
    _______________________________________________________
    daj znać czy może i u Ciebie pomogło

  • ebeneben

    mam jeszcze pytanie czy działa ci „perian” a może w nowym QT 10 już go nie potrzeba?

  • ebeneben: w preferencjach obecnie mam AppTrap, Flip4Mac, KeyRemap4MacBook, Perian i Wacom – wszystko niezbędne. Niewykluczone że jedno z nich spowalnia system, ale korzystam niestety z nich. Może w wolnej chwili testy zrobię.

    Perian działa z QT X.

  • Chino

    Witaj Moridin,
    Zainstalowałem drivery do Intuosa 4 bez żadnych problemów. Do tej pory sprawdziłem w illustratorze nie ma żadnych bagów.

    Pozdrawiam.

  • U mnie bez problemu chodzi.

  • Pingback: Snow Leopard | Makowe ABC()